Getting "Please Login" message when trying to use API Token

I’m trying to test in Postman using the API token from one of my Kintone apps. I’ve tried to follow the docs as closely as possible, but am not sure what I’m missing. All I want to do is pull the records from the app to view. 


And then I have: X-Cybozu-API-Token:[my api token here]

Type Basic Auth

“code”: “CB_AU01”,
“id”: “5lWI0Q80ERRxOsenuzVk”,
“message”: “Please login.”


Hi Heather,


When I tried Postman, I have not seen the message “Please login.”

I would think the error has occurred due to the followings.

  1. The incorrect parameter is requested.

Please double check the URL.

  1. The API token generated has not been reflected in the current App.

    Please make sure to click on “Update App” after the API token is generated and saved in the Setting.

Here is how I configured in the Postman setting.

 * Please add key “X-Cybozu-API-token” and value of the generated API token under “Header” tab.

To get all of the records, you will need to add “s” after “record” on the URL as below.

To get one record:

(Please make sure the record exists in App.)

URL: &id=1









Hello! Thanks Junko! This is great! I got a successful return in Postman - but I’ve also switched to Basic Authentication. This will apply also, I’m assuming?


Thanks again!


Hello Heather,

I am glad you got the problem solved.

Please refer to the following link for User Authentication.
There is a section explaining Basic Authentication in the link as well.

Thank you,


I’ve still got an issue with this - not sure if you can help me - but I figured I’d at least try. 

So I’ve got Basic Authentication set up correctly and have tested in Postman - all works great. I am now trying to do the same exact thing in Power BI. I’ve outlined the issue here: 


would you have ANY idea why it won’t accept the ‘?app=210’ part of the URL? I know this isn’t your area specifically - but I’m kind of desperate to try and get this working. So I’m trying everything.

If you can’t - completely understand. Thanks! :slight_smile:


Hi Heather,
I have never used Power IB before, so I installed it and included the following info on the set-up “From Web” screen.

Somehow, I did not see “Access Web content” screen and was able to get the data below successfully  .

What I realized is that if I input the wrong URL, I was navigated to “Access Web content”. Then as you said, under “Anonymous” tab, the URL does not have the full address as I specified but without “?app=154”(in my case). Therefore, I would suggest you to double check the URL on  “From Web”. Hope it helps.

I don’t get it. :frowning: My settings are the exact same as yours…  I’ve checked the URL - it’s the same exact one you listed in the earlier part of this forum. It works in my Postman (and in your’s). I have no idea…


Thank you for your help with this. At least I know it IS, indeed, possible. Something is off -  I just can’t figure out what

I Got it!!! :D 


Thank you for your help - so much! :D 


Hi Junko,

When you are adding the API token to the header, what it the Authentication method? I can only get this to work in Postman when using Basic Auth with Username: X-Cybozu-API-Token and the password as my API token.