Problem mapping files with multiple Attachment fields using Make/Integromat

In Make (formerly Integromat), the Attachment fields have the following settings:
Add Attachment with Yes, No, and Empty as the options.

Once you select Yes, you add the filekey, and it works.

Well, it worked until I added a 2nd Attachment field.
(I will be adding many more once I figure out this issue.)

The problem is, with two fields, if I choose Yes for Attachment field 1, then Make automatically sets Attachment field 2 to Yes as well.

The files for these fields are updated in separate scenarios at different times with different triggers.

Why are the Attachment Fields synched like this in Make?
Is there a way that I can send data to only one Attachment field and not the other?

I tried setting the unneeded field to Ignore and Null. But that doesn’t work either.

Hello @Larah_Ritchie ,

I’m not sure how Kintone and Make (Integromat) integrate, but it looks similar to Zapier.

I want to recreate the issue, so could you be more specific in how you set up the scenario in Make?

I just created an account for Make, but there seem to be other settings besides connecting to the Kintone domain.

Thank you

My apologies for the delay in getting back to you. Life has kept me away from work for the last few weeks.

Setup Overview

I am using Make to move data from Gravity Forms on a WordPress website into a Kintone App.

Scenario 1 - Create a Record

The “create a record” scenario starts with a webhook watching for new entries in Gravity Forms.

And, after some complex array aggregation, it creates a new record in Kintone.

This new record includes the PDF for the Attachment Field.

The PDF is generated by a Gravity Forms Add-On.

The scenario passes that file into the Kintone’s Attachment Field using Make’s “Upload a File” module… along with all of the other data for that record (something like 80 fields).

That whole process was working well until I added the second Attachment Field.

Scenario 2 - Follow-up Process

Now we need to add the follow-up processes that request additional documents from the clients.

Those requests are sent from Mailgun via Make based on triggers in Kintone.

That scenario works well.

Once they complete the requested Gravity Form, the PDF is again generated by the Gravity Forms Add-On.

Then another scenario in Make moves the PDF to Kintone.

This scenario connects directly to Gravity Forms with a Make module that listens for new entries every 15 minutes.

The scenario passes the PDF file into the Attachment Field in Kintone using Make’s “Upload a File” module and “Update a Record” module.

It works…

But this is when things got weird.

The Problem

The Kintone app now has these two document Attachment Fields (so far).

With 2 Attachment Fields, both Make scenarios are acting like there is only one field.

Any changes I make to Make’s “add attachment” option on one field is also applied to the other.

In the first scenario, I need to ONLY add attachment 1 and ignore attachment 2.

In the 2nd scenario, I need to ONLY add attachment 2 and ignore attachment 1.

Question

Is there a way that I can send data to only one Attachment field and not the other?

@Larah_Ritchie , thank you for adding more information on your Make x Kintone setup.

Since our team is not familiar with Make, please share screenshots of your Make settings.

As Chris was saying earlier, we want to recreate the issue you are having.
Thank you for your time ~

Hi Chris & Genji. Thank you both so much for continuing to follow up with this issue. I made a screencast video walking you through the Make scenario. I appreciate any insight you might have on this!

To clarify, around 3:58 in the video, I show how Make is saying the HIF is a required field which is what is causing the upload scenario to fail. But neither of the attachment fields in the Kintone app are actually required fields.

1 Like

Hello @Larah_Ritchie

I was able to recreate the issue.
I simply added two Attachment fields in a new App, nothing else.
And then connected the App to Make.
When I checked the attachment settings on the Make side, both settings seemed to be somehow syncing, as you mentioned.

This must be a bug on the Make side, but I will contact Kintone about this if they can do anything about it.

For now, I think found a temporary solution for this:

Video

0:00-0:28 | Showing the attachment fields are syncing.

When both settings are set to Yes, an error shows both fields are Required fields, as you mentioned.

0:28-0:56 | Temporary Solution

  1. Change the 1st Add Attachment to Map
  2. Delete the value in the 1st Add Attachment (this will automatically change the 2nd Add Attachment to Empty too)
  3. Add true to the 1st Add Attachment value (somehow, this doesn’t change the 2nd Add Attachment value)
  4. (I didn’t do this in the video, but) Add the filekey and click on save.

0:56-1:05 | Testing the fixed scenario

After the above changes, an error only shows the 1st attachment field is required (since I didn’t add a filekey), nothing about the 2nd attachment field, so the temporary fix seems to work.

1:05-1:22 | Another bug

HOWEVER, when I go back to the “Kintone Update A Record” settings, the attachment settings somehow revert.

I hope this helps.

1 Like

Thank you so much for taking the time to recreate this.

Sadly, the temporary solution is not working because it continues to revert both fields &/or stop the scenario for a ‘required’ field.

Hopefully, Kintone can offer some guidance.
I will also send them a link to this conversation to see if they have suggestions for moving forward.

1 Like

Hello @Larah_Ritchie ,

Please test the Make.com x Kintone integration once more!

Make.com’s support team responded, saying the fix to the bug you have encountered has been deployed.

Please let us know if the multiple Attachment field integration worked or if you got another error.

Thank you for your patience ~